Error message when attempting to print

Having problems with the forum software, or suggestions for improvements

Error message when attempting to print

Postby baobab » Sun Apr 17, 2005 10:11 am

Whilst using the demo version I had no problem, but after paying and registering, I receive the following message after clicking on the PRINT icon:

"For security purposes, this program will not run while system debuggers are active. Please remove or disable the system debugger before trying to run this program again." Sudoko then totally locks up.

I can find nothing in the WIN-XP help file about a system debugger, apart from general advice on troubleshooting hardware problems. Disabling WIN-XP error reporting (and re-booting) hasn't helped.

Any suggestions please?
Posts: 3
Joined: 17 April 2005

Postby Pappocom » Sun Apr 17, 2005 11:39 am

Hello baobab. I haven't had any reports of this, previously. I'm researching it, and will make another post here in the near future.

- Wayne.
Posts: 599
Joined: 05 March 2005

Postby Pappocom » Tue Apr 19, 2005 3:32 am

Hello again, baobab.

The message you describe is put up by the anti-piracy shell that wraps the Sudoku program. The makers of the anti-piracy program advise me that the message can appear only at program start-up. As the message appears after you have started up Sudoku and only when you start to print, it means that the problem is caused by a program (not the Sudoku program) that starts up only when you go to print (and by a program which uses the same 3rd-party anti-piracy program that Sudoku uses - it's a common program.)

Do you have any programs installed which are supposed to help your printer in some way? ... perhaps FinePrint or one of those programs which helps you format your output or lets you print to a file, etc.?

Did you install any program of that kind at about the time you purchased Sudoku?

You could try disabling your other programs, one by one, until you find the program that is causing the conflict.

The mere act of purchasing the Sudoku program does not alter the Sudoku program code in any significant way. Entering the Registration Code into the program does not cause any new code to be executed or any new DLLS to be loaded. If the program was working before purchase, there is no reason why it should not be working after purchase. If it appears that the program stopped working because of purchase, there must be some coincidental event.

I’m sorry I cannot shed any more light on it than that. I am happy to look at the issue again, of course, if you can provide me with more information.

If the problem persists and you cannot trace the reason, please contact me to arrange a refund of your purchase price.

- Wayne
Posts: 599
Joined: 05 March 2005

Postby baobab » Tue Apr 19, 2005 8:24 pm

Thank you for your speedy reply.

The message mentioned previously comes on-screen as soon as the print icon on the option bar is clicked. On clicking <OK> to remove, it is repeated a further nine times after which the following appears

LoadLibrary Failure;
C:\WINDOWS\SYSTEM32\SPOOL\DRIVERS\W32X86\3\ISSHEL00.DLL GetLastError()1114 and is repeated over and over again.

Nothing appears in the Grid Impression or Page Impression areas at any time. (No new programmes or dll's appear in the Task Manager window after clicking the print icon.)

I assume that the programme is preparing the Windows "print function" at this point, even though no print choices have been made.

I thought the conflict may have been caused by INKSAVER software running in the background, but even when this is uninstalled the problem is still there. Blue Squirrel's "CLICKBOOK" is also used, but, again, when this in uninstalled there is no improvement! I have selectively removed various programmes from memory one-by-one using Task Manager and things are no better.

A test installation on another XP PC works perfectly even when CLICKBOOK is running; I haven't had time to test that PC with INKSAVER however.

I've tried uninstalling Sudoku and both the above print management programmes, and then re-installing Sudoku on the "clean" machine. No improvement. Will test various combinations of uninstall / re-install during the next few days, and provide further feedback then. In the meantime any further suggestions will be appreciated.

Thanks for your efforts.......

Posts: 3
Joined: 17 April 2005

Postby Pappocom » Tue Apr 19, 2005 9:04 pm

Thanks for the extra information, Vic. That could be quite useful. I will do some more research and get back to you.

If InkSaver and/or ClickBook are protected with the same anti-piracy shell as I use, it might well be that even though you have Removed or Uninstalled those programs, my Sudoku program is reacting as if they are still there. That is because when you uninstall a protected program, part of the anti-piracy keys remain. That is industry-standard behaviour, and is necessary to prevent the demo version being used and re-used time after time.

- Wayne
Posts: 599
Joined: 05 March 2005

Problem, apparently, solved!

Postby baobab » Wed Apr 20, 2005 7:58 pm

1. Used Win-XP to uninstall ALL printers. I have two in use.
2. Re-booted (with printers disconnected).
3. Created a Restore Point.
4. Disabled anti-virus software.
5. Switched Outpost Firewall to block all traffic.
6. Attempted re-install of Canon printer, unsuccessfully.
7. Uninstalled ancillary printer software (album, web-page-print and other "extras")
8. Rebooted and disabled as in 4 and 5 above.
9. Re-installed printer using CD and not by means of normal plug-and-play.
10. Created a further Restore Point.
11. Tested Sudoku - successfully.
12. Re-installed INKSAVER, and tested Sudoku - successfully again.
13. Configured CLICKBOOK adding Canon printer, and Sudoku still worked.

The Canon printer was purchased a few days after installing Sudoku demo; it seems likely that something went wrong during plug-and-play installation of the Canon drivers.

Thank you Wayne for all your work on my query - much appreciated. Think I'll now switch off, and relax with old fashioned pencil and Sudoku for a couple of hours!!
Posts: 3
Joined: 17 April 2005

It's an inksaver related problem

Postby chermesh » Wed Apr 26, 2006 9:41 am

I'm not a sudoku player and all I got was an identical problem, related specifically to inksaver.
Still, I solved my problem, or rather put it aside, from inside inksaver. While you uninstall inksave, you encounter the option of dropping a printer. I dropped my problematic printer from the list and the problem disappeared.
So, inksaver is still installed on my system, waiting for a solution to the printing error, and printing is available to all my printing related applications.

Posts: 1
Joined: 26 April 2006

Return to Forum questions and feedback