Corrupt Linkage in Database ???

Having problems with the forum software, or suggestions for improvements

Corrupt Linkage in Database ???

Postby daj95376 » Sun Nov 05, 2006 11:20 pm

This thread thinks there are nine sections. However, trying to get past section eight results in an error message.
daj95376
2014 Supporter
 
Posts: 2624
Joined: 15 May 2006

Postby udosuk » Mon Nov 06, 2006 11:25 am

If it's the database problem then only the IT department of the phpbb company can fix it, and I don't think the administrator of this forum can do much about it... However, I think we (the users) can fix it ourselves by posting 5-6 more posts on that thread to make the "p.9" really valid, and then delete the posts one by one and see if the "p.9" would disappear properly... Just a thought...:idea:

BTW I think this particular sub-forum is for the tech support of the Pappocom software, and technical problems regarding the forum itself should go to the "Off-Topic" sub-forum...:?:
udosuk
 
Posts: 2698
Joined: 17 July 2005

Postby MCC » Mon Nov 06, 2006 4:58 pm

udosuk wrote:...BTW I think this particular sub-forum is for the tech support of the Pappocom software, and technical problems regarding the forum itself should go to the "Off-Topic" sub-forum...:?:

IMHO, I think Scott will be more likely to see it here than in the ""Off-Topic" forum.
Even if he cannot help, he can offer some advice.

MCC
MCC
 
Posts: 1275
Joined: 08 June 2005

Postby Son of Pappocom » Mon Nov 06, 2006 7:36 pm

Seems to be a semi-common occurence with phpBB. I've found a support thread with various ideas on how to fix the problem -- stay tuned.

Regards
Scott
Son of Pappocom
 
Posts: 217
Joined: 10 October 2005

Postby Son of Pappocom » Mon Nov 06, 2006 10:42 pm

Well, they're not making it easy. phpBB's own forums' search facility appears to be broken.

It seems that the post count for a thread is kept separately. When removing members from the board (for spam, voluntary deletion, or whatever) the users' posts are removed correctly but the count for posts in a given thread is not decremented reliably. In other words, if you counted up the total replies to that thread over time, you would be on page 10, but enough posts have been removed that there are only nine pages' worth right now.

So I know what the problem is likely to be, but not how to fix it. Google suggests everything from a "resync" (which I've tried and didn't work) to a database restore (which would mean a loss of some posts, so I don't want to do that if possible). It seems to be a fairly common occurrence, but there's no clear resolution.

Regards
Scott
Son of Pappocom
 
Posts: 217
Joined: 10 October 2005

re: vanished

Postby Pat » Fri Jun 01, 2007 6:37 am

User avatar
Pat
 
Posts: 3440
Joined: 18 July 2005

Postby daj95376 » Mon Jun 04, 2007 9:53 pm

Well, rep'nA posted to a lot of threads, and multiple threads are now starting to show problems.

Maybe it's time that phpBB came up with a reliable way to re-sync the thread counts!!!
daj95376
2014 Supporter
 
Posts: 2624
Joined: 15 May 2006


Return to Forum questions and feedback